dart_browser_loader 0.0.5

dart_browser_loader #

Import Javascript/Css... using Dart

await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
await loadLink("https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
await loadInlineStyle('''
  body {
    color: red;
  }
  ''');

It will add following element to dom.

<script type="text/javascript" async="" src="https://code.jquery.com/jquery-3.2.1.min.js"></script>
<link type="text/css" rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css">
<style>  body {
    color: red;
  }
 </style>

All function return future with element when link is valid or throw an error when invalid.

Changelog #

0.0.5 #

  • dart 2 stable

0.0.4 #

  • support inline script

0.0.3 #

  • better performance
  • fix blocking load when call multiple time

0.0.2 #

  • add defer to loadScript

0.0.1 #

  • Initial version, created by Stagehand

example/main.dart

import '../lib/dart_browser_loader.dart';

main() async {
  await loadScript("https://code.jquery.com/jquery-3.2.1.min.js");
  await loadLink(
      "https://maxcdn.bootstrapcdn.com/bootstrap/4.0.0-beta.2/css/bootstrap.min.css");
  await loadInlineStyle('''
  body {
    color: red;
  }
  ''');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_browser_loader: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_browser_loader/dart_browser_loader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
82
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:dart_browser_loader/dart_browser_loader.dart with components: html.

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/script.dart. (-1.99 points)

Analysis of lib/src/script.dart reported 4 hints:

line 10 col 17: Use = to separate a named parameter from its default value.

line 11 col 17: Use = to separate a named parameter from its default value.

line 12 col 16: Use = to separate a named parameter from its default value.

line 40 col 17: Use = to separate a named parameter from its default value.

Fix lib/src/style.dart. (-1 points)

Analysis of lib/src/style.dart reported 2 hints:

line 21 col 27: Use = to separate a named parameter from its default value.

line 21 col 54: Use = to separate a named parameter from its default value.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
Dev dependencies
test ^1.3.0

Admin