The AngularDart router enables navigation from one view to the next as users perform application tasks.
The 1.0 version of
angular_router is just a port of the router that was in
angular package. Only critical bug fixes are planned for the 1.0
router. A significant refactoring is in progress, which is expected to result
in a 2.0 version of
angular_router. This is just a port of the router that was in the core angular package.
Add this to your package's pubspec.yaml file:
dependencies: angular_router: ^1.0.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.24.0 <2.0.0|