essential_components 0.1.3

A library for AngularDart developers. under construction

Usage #

A simple usage example under construction:

import 'package:essential_components/essential_components.dart';

0.0.4 #

  • Initial version pre alpha

0.0.5 #

  • Fix analysis problems

0.0.6 #

  • Refactoring components names

0.0.7 #

  • Refactoring API names

0.0.8 #

  • Fix bug on DataTable component

0.1.0 #

  • Fix preventDefault and stopPropagation for form submission on enter key

0.1.1 #

  • implementation of a loading animation in dataTable

0.1.2 #

  • implementation directives utils

0.1.3 #

  • fix CSS dataTable

example/README.md

example #

A web app that uses AngularDart and AngularDart Components.

Created from templates made available by Stagehand under a BSD-style license.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  essential_components: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:essential_components/essential_components.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
25
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
62
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Aug 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: web

Primary library: package:essential_components/essential_components.dart with components: html, js.

Health suggestions

Fix lib/src/directives/textmask_directive.dart. (-1.99 points)

Analysis of lib/src/directives/textmask_directive.dart reported 4 hints:

line 12 col 33: 'OnChanges' is deprecated and shouldn't be used.

line 103 col 3: The method '_selectText' isn't used.

line 116 col 8: The method '_isNumeric' isn't used.

line 120 col 28: 'onError' is deprecated and shouldn't be used.

Fix lib/src/data_table/data_table_future.dart. (-1.49 points)

Analysis of lib/src/data_table/data_table_future.dart reported 3 hints:

line 4 col 8: Unused import: 'package:intl/intl.dart'.

line 13 col 8: Unused import: 'data_table_utils.dart'.

line 90 col 7: The value of the field '_btnQuantity' isn't used.

Fix lib/src/directives/money_mask_directive.dart. (-1 points)

Analysis of lib/src/directives/money_mask_directive.dart reported 2 hints:

line 68 col 3: The method '_validateConfig' isn't used.

line 69 col 34: Use isNotEmpty instead of length

Fix additional 10 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/directives/maxlength_directive.dart (1 hint)
  • lib/src/data_table/data_table.dart (Run dartfmt to format lib/src/data_table/data_table.dart.)
  • lib/src/data_table/data_table_utils.dart (Run dartfmt to format lib/src/data_table/data_table_utils.dart.)
  • lib/src/directives/ano_validator.dart (Run dartfmt to format lib/src/directives/ano_validator.dart.)
  • lib/src/directives/datetime_value_accessor.dart (Run dartfmt to format lib/src/directives/datetime_value_accessor.dart.)
  • lib/src/directives/decimal_value_accessor.dart (Run dartfmt to format lib/src/directives/decimal_value_accessor.dart.)
  • lib/src/notification/notification.dart (Run dartfmt to format lib/src/notification/notification.dart.)
  • lib/src/notification/notification_services.dart (Run dartfmt to format lib/src/notification/notification_services.dart.)
  • lib/src/select_dialog/select_dialog.dart (Run dartfmt to format lib/src/select_dialog/select_dialog.dart.)
  • lib/src/toast/toast.dart (Run dartfmt to format lib/src/toast/toast.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (angular, angular_components, angular_forms).

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
angular ^5.3.0 5.3.1 6.0.0-alpha+1
angular_components ^0.13.0 0.13.0+1 0.14.0-alpha+1
angular_forms ^2.0.0 2.1.2 2.1.4
decimal ^0.3.4 0.3.4
intl ^0.15.8 0.15.8
ng_fontawesome ^5.7.2+2 5.7.2+2
sass_builder ^2.1.3 2.1.3
Transitive dependencies
analyzer 0.35.4 0.38.0
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
args 1.5.2
async 2.3.0
build 1.1.6
build_config 0.4.1+1
built_collection 4.2.2
built_value 6.7.0
charcode 1.1.2
checked_yaml 1.0.2
cli_repl 0.2.0+1
code_builder 3.2.0
collection 1.14.12
convert 2.1.1
crypto 2.1.2
csslib 0.14.6+1 0.16.1
dart_internal 0.1.6
dart_style 1.2.4 1.2.10
fixnum 0.10.9
front_end 0.1.14 0.1.22
glob 1.1.7
http 0.12.0+2
http_parser 3.1.3
js 0.6.1+1
json_annotation 3.0.0
kernel 0.3.14 0.3.22
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
observable 0.22.2
package_config 1.1.0
package_resolver 1.0.10
path 1.6.4
protobuf 0.13.15
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.0.5
rational 0.3.5
sass 1.22.10
source_gen 0.9.4+3
source_maps 0.10.8
source_span 1.5.5
stack_trace 1.9.3
stream_transform 0.0.19
string_scanner 1.0.5
term_glyph 1.1.0
tuple 1.0.2
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.1.16
Dev dependencies
pedantic ^1.7.0 1.8.0+1
test ^1.6.0