essential_codemod 0.1.5
essential_codemod: ^0.1.5

Dart native
Flutter Android iOS

A collection of codemods to upgrade your code

1
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 99 API elements (19.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:essential_codemod/helpers/file_manager.dart that imports:
  • package:essential_codemod/modifiers/patch.dart that imports:
  • package:essential_codemod/helpers/logging.dart that imports:
  • package:io/ansi.dart that imports:
  • package:io/src/ansi_code.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

INFO: Unused import: 'package:path/path.dart'.

bin/codechange.dart:2:8

  ╷
2 │ import 'package:path/path.dart' as path;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/codechange.dart

INFO: Unused import: 'package:args/args.dart'.

bin/codechange.dart:3:8

  ╷
3 │ import 'package:args/args.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/codechange.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.37.0 <0.39.00.38.50.41.0
args>=1.5.1 <2.0.01.6.01.6.0
codemod>=0.1.5 <0.2.00.1.50.2.0
io^0.3.30.3.40.3.4
logging^0.11.40.11.40.11.4
meta^1.1.81.2.41.2.4
path^1.6.41.7.01.7.0
source_span>=1.4.1 <2.0.01.7.01.7.0
stack_trace^1.9.31.9.61.9.6
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
file-5.2.15.2.1
front_end-0.1.270.1.29
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl-0.16.10.16.1
js-0.6.20.6.2
kernel-0.3.270.3.29
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
pub_semver-1.4.41.4.4
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.37.0 <0.39.0` on analyzer does not support the latest published version `0.41.0`

pubspec.yaml:11:13

   ╷
11 │   analyzer: '>=0.37.0 <0.39.0'
   │             ^^^^^^^^^^^^^^^^^^
   ╵
The constraint `>=0.1.5 <0.2.0` on codemod does not support the latest published version `0.2.0`

pubspec.yaml:12:12

   ╷
12 │   codemod: '>=0.1.5 <0.2.0'
   │            ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs