essential_codemod 0.1.5
essential_codemod: ^0.1.5 copied to clipboard

A collection of codemods to upgrade your code

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate essential_codemod

Use it

The package has the following executables:

$ codechange

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add essential_codemod

With Flutter:

 $ flutter pub add essential_codemod

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  essential_codemod: ^0.1.5

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:essential_codemod/helpers/file_manager.dart';
import 'package:essential_codemod/helpers/logging.dart';
import 'package:essential_codemod/modifiers/code_template.dart';
import 'package:essential_codemod/modifiers/implements_json_serialization.dart';
import 'package:essential_codemod/modifiers/patch.dart';
import 'package:essential_codemod/modifiers/scan_class_models.dart';
import 'package:essential_codemod/type_definictions/core_types.dart';