enough_mail 2.1.6 copy "enough_mail: ^2.1.6" to clipboard
enough_mail: ^2.1.6 copied to clipboard

IMAP, POP3 and SMTP for email developers. Choose between a low level and a high level API for mailing. Parse and generate MIME messages. Discover email settings.

108
likes
130/ 140
pub points
92%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1488 out of 1488 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:enough_mail/enough_mail.dart that imports:
  • package:enough_mail/smtp.dart that imports:
  • package:enough_mail/src/smtp/smtp_exception.dart that imports:
  • package:enough_mail/src/smtp/smtp_client.dart that imports:
  • package:enough_mail/src/private/util/client_base.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/codecs.dart:1:1

  ╷
1 │ /// Email codec classes
  │ ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/codecs.dart

INFO: Dangling library doc comment.

lib/discover.dart:1:1

  ╷
1 │ /// Discovers email settings based on an email address.
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/discover.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
basic_utils ^5.6.1 5.7.0 5.7.0
collection ^1.16.0 1.18.0 1.18.0
crypto ^3.0.0 3.0.3 3.0.3
encrypt ^5.0.0 5.0.3 5.0.3
enough_convert ^1.5.0 1.6.0 1.6.0
event_bus ^2.0.0 2.0.0 2.0.0
intl ^0.19.0 0.19.0 0.19.0
json_annotation ^4.8.0 4.8.1 4.8.1
pointycastle ^3.6.0 3.9.0 3.9.0
synchronized ^3.1.0 3.1.0+1 3.1.0+1
xml >=6.0.0 <7.0.0 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
logging - 1.2.0 1.2.0
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

108
likes
130
pub points
92%
popularity

Publisher

verified publisherenough.de

IMAP, POP3 and SMTP for email developers. Choose between a low level and a high level API for mailing. Parse and generate MIME messages. Discover email settings.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

basic_utils, collection, crypto, encrypt, enough_convert, event_bus, intl, json_annotation, pointycastle, synchronized, xml

More

Packages that depend on enough_mail