easy_localization_loader 0.0.2
easy_localization_loader: ^0.0.2

Flutter Android iOS

Easy Localization Loader custom assets loaders for easy_localization (Json, CSV, http, Xml, API ...)

11
likes
60 / 110
pub points
90 %
popularity

We analyzed this package on Nov 28, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 45 API elements (4.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:easy_localization_loader/easy_localization_loader.dart that imports:
  • package:easy_localization_loader/src/file_asset_loader.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/easy_localization_loader.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
csv^4.0.34.1.04.1.0
http^0.12.0+20.12.20.12.2
xml^3.5.03.7.04.5.1
yaml^2.2.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
petitparser-3.1.03.1.0
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.5.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:16:8

   ╷
16 │   xml: ^3.5.0
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

11
likes
60
pub points
90%
popularity

Easy Localization Loader custom assets loaders for easy_localization (Json, CSV, http, Xml, API ...)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mr.aissat@gmail.com

License

MIT (LICENSE)

Dependencies

csv, flutter, http, xml, yaml

More

Packages that depend on easy_localization_loader