djangoflow_app 3.7.5 copy "djangoflow_app: ^3.7.5" to clipboard
djangoflow_app: ^3.7.5 copied to clipboard

A simple, opinionated, and minimal Flutter application structure for quick start and easy maintenance.

0
likes
120/ 140
pub points
61%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

44 out of 102 API elements (43.1 %) have documentation comments.

Some symbols that are missing documentation: df_app, df_app.AppBuilder, df_app.AppBuilder.AppBuilder, df_app.AppBuilder.onDispose, df_app.AppBuilder.onInitState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:djangoflow_app/djangoflow_app.dart that imports:
  • package:djangoflow_app/src/utils/djangoflow_app_runner.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:djangoflow_app/djangoflow_app.dart that imports:
  • package:djangoflow_app/src/utils/extensions/package_info_extensions.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:djangoflow_app/djangoflow_app.dart that imports:
  • package:djangoflow_app/src/utils/extensions/package_info_extensions.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:djangoflow_app/djangoflow_app.dart that imports:
  • package:djangoflow_app/src/utils/extensions/package_info_extensions.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:djangoflow_app/djangoflow_app.dart that imports:
  • package:djangoflow_app/src/utils/extensions/package_info_extensions.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/bloc/app_cubit.freezed.dart:179:17

    ╷
179 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc/app_cubit.freezed.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.3.2 5.4.1 5.4.1
flutter flutter 0.0.0 0.0.0
flutter_bloc ^8.1.3 8.1.4 8.1.4
flutter_localizations flutter 0.0.0 0.0.0
freezed_annotation ^2.4.1 2.4.1 2.4.1
hydrated_bloc ^9.1.2 9.1.4 9.1.4
json_annotation ^4.8.1 4.8.1 4.8.1
package_info_plus ^5.0.1 5.0.1 5.0.1
path_provider ^2.1.1 2.1.2 2.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
bloc - 8.1.3 8.1.3
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
hive - 2.2.3 2.2.3
http - 1.2.0 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
package_info_plus_platform_interface - 2.0.1 2.0.1
path - 1.9.0 1.9.0
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.4.2 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
120
pub points
61%
popularity

Publisher

verified publisherapexive.com

A simple, opinionated, and minimal Flutter application structure for quick start and easy maintenance.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, flutter_bloc, flutter_localizations, freezed_annotation, hydrated_bloc, json_annotation, package_info_plus, path_provider

More

Packages that depend on djangoflow_app