dirt_arch 0.0.6
dirt_arch: ^0.0.6 copied to clipboard

This package has the reference of many packages to facilitate the creation of apps without having to look for packages

3
likes
70 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 118 API elements (14.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dirt_arch/dirt_arch.dart that imports:
  • package:flutter_form_builder/flutter_form_builder.dart that imports:
  • package:flutter_form_builder/src/fields/form_builder_phone_field.dart that imports:
  • package:phone_number/phone_number.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Close instances of `dart.core.Sink`.

lib/src/hasura_components/subscription/subscription_widget.dart:35:11

   ╷
35 │       var result = await hasuraConnect.subscription(widget.subscription);
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/hasura_components/subscription/subscription_widget.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animated_card^1.0.0+81.0.0+82.0.0
asuka^1.0.41.0.41.0.4
bot_toast^3.0.53.0.54.0.1
bubble_bottom_bar^1.2.01.2.01.2.0
connectivity^2.0.22.0.23.0.3
convex_bottom_bar^2.4.12.7.1+23.0.0
dio^3.0.103.0.104.0.0
flutterflutter0.0.00.0.0
flutter_form_builder^3.14.13.14.16.0.0
flutter_modular^2.0.12.0.13.2.0
google_fonts^1.1.01.1.22.0.0
hasura_connect^2.0.02.0.13.0.2
mask_text_input_formatter^1.1.01.2.11.2.1
meta^1.1.81.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.0
async-2.6.12.6.1
basic_utils-2.7.13.0.2
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
convert-2.1.13.0.0
country_pickers-1.3.02.0.0
crypto-2.1.53.0.1
dartz-0.9.20.9.2
date_range_picker-1.0.71.0.7
datetime_picker_formfield-1.0.02.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_chips_input-1.9.51.9.5
flutter_colorpicker-0.3.50.4.0
flutter_keyboard_visibility-4.0.65.0.1
flutter_keyboard_visibility_platform_interface-1.0.12.0.0
flutter_keyboard_visibility_web-1.0.12.0.0
flutter_plugin_android_lifecycle-1.0.112.0.1
flutter_touch_spin-1.0.11.0.1
flutter_typeahead-1.9.33.1.3
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
image-2.1.193.0.2
image_picker-0.6.7+220.7.4
image_picker_for_web-0.1.0+22.0.0
image_picker_platform_interface-1.1.62.1.0
intl-0.16.10.17.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
logging-0.11.41.0.1
path-1.8.01.8.0
path_provider-2.0.12.0.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
phone_number-0.6.30.10.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
pointycastle-2.0.13.0.1
process-4.2.14.2.1
random_string-2.1.02.1.0
rating_bar-0.2.00.2.0
signature-3.2.14.1.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
string_validator-0.1.40.3.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
validators-2.0.13.0.0
vector_math-2.1.02.1.0
vin_decoder-0.1.30.1.3
websocket-0.0.50.0.5
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0
xml-4.5.15.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^1.0.0+8` on animated_card does not support the stable version `2.0.0`, that was published 21 days ago.

When animated_card is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions animated_card to update the constraint.

The constraint `^3.0.5` on bot_toast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions bot_toast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

3
likes
70
pub points
0%
popularity

This package has the reference of many packages to facilitate the creation of apps without having to look for packages

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

bwolfnoob@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

animated_card, asuka, bot_toast, bubble_bottom_bar, connectivity, convex_bottom_bar, dio, flutter, flutter_form_builder, flutter_modular, google_fonts, hasura_connect, mask_text_input_formatter, meta

More

Packages that depend on dirt_arch