dds 4.2.3 copy "dds: ^4.2.3" to clipboard
dds: ^4.2.3 copied to clipboard

A library used to spawn the Dart Developer Service, used to communicate with a Dart VM Service instance.

15
likes
160/ 160
pub points
99%
popularity

We analyzed this package 30 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

793 out of 1759 API elements (45.1 %) have documentation comments.

Some symbols that are missing documentation: dap, dap.AttachRequestArguments.canParse, dap.AttachRequestArguments.fromJson, dap.AttachRequestArguments.AttachRequestArguments.fromMap, dap.AttachRequestArguments.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dds/dds.dart that imports:
  • package:dds/src/dds_impl.dart that imports:
  • package:dds/src/stream_manager.dart that imports:
  • package:dds/src/logging_repository.dart that imports:
  • package:dds/src/client.dart that imports:
  • package:dds/src/dap/adapters/dds_hosted_adapter.dart that imports:
  • package:dds/src/dap/adapters/mixins.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
async ^2.4.1 2.11.0 2.11.0
browser_launcher ^1.0.0 1.1.1 1.1.1
collection ^1.15.0 1.19.0 1.19.0
dap ^1.2.0 1.2.0 1.2.0
dds_service_extensions ^2.0.0 2.0.0 2.0.0
devtools_shared ^10.0.0-dev.1 10.0.1 10.0.1
extension_discovery ^2.0.0 2.0.0 2.0.0
http_multi_server ^3.0.0 3.2.1 3.2.1
json_rpc_2 ^3.0.0 3.0.2 3.0.2
meta ^1.1.8 1.15.0 1.15.0
mime ^1.0.2 1.0.5 1.0.5
path ^1.8.0 1.9.0 1.9.0
shelf ^1.0.0 1.4.1 1.4.1
shelf_proxy ^1.0.0 1.0.4 1.0.4
shelf_static ^1.0.0 1.1.2 1.1.2
shelf_web_socket >=1.0.0 <3.0.0 2.0.0 2.0.0
sse ^4.0.0 4.1.5 4.1.5
stack_trace ^1.10.0 1.11.1 1.11.1
stream_channel ^2.0.0 2.1.2 2.1.2
vm_service ^14.0.0 14.2.4 14.2.4
web_socket_channel >=2.0.0 <4.0.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dtd - 2.2.0 2.2.0
file - 7.0.0 7.0.0
http - 1.2.1 1.2.1
http_parser - 4.1.0 4.1.0
intl - 0.19.0 0.19.0
logging - 1.2.0 1.2.0
pool - 1.5.1 1.5.1
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
unified_analytics - 6.1.1 6.1.1
web - 0.5.1 0.5.1
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2
yaml_edit - 2.2.1 2.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.