datamuse 0.1.2
datamuse: ^0.1.2 copied to clipboard

Datamuse API client for Dart/Flutter provides word-finding query engine.

1
likes
100/ 130
pub points
31%
popularity

We analyzed this package on Sep 23, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 33 out of 62 API elements (53.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.3.24.3.25.1.1
built_value^7.1.07.1.08.1.2
dio^3.0.103.0.104.0.0
json_annotation^3.0.13.1.14.1.0
meta^1.2.21.7.01.7.0
pedantic^1.9.21.11.11.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
matcher-0.12.110.12.11
path-1.8.01.8.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.3.2` on built_collection does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

The constraint `^7.1.0` on built_value does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions built_value to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Dart 2.14.1.

1
likes
100
pub points
31%
popularity

Publisher

vojtech.net

Datamuse API client for Dart/Flutter provides word-finding query engine.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

built_collection, built_value, dio, json_annotation, meta, pedantic

More

Packages that depend on datamuse