datamuse 0.3.0 copy "datamuse: ^0.3.0" to clipboard
datamuse: ^0.3.0 copied to clipboard

Datamuse API client for Dart/Flutter provides word-finding query engine.

Datamuse API #

Pub Version

Library for using Datamuse API to find words using specific queries.

Query #

You can find words using specific queries.

Future<List<Result>> query({
    String? meansLike,
    String? soundsLike,
    String? spelledLike,
    List<LexicalRelation> relations = const [],
    Vocabulary vocabulary = Vocabulary.basic,
    List<String> topics = const [],
    String? leftContext,
    String? rightContext,
    int max = 100,
    List<MetadataFlag> metadata = const [],
    String? queryEcho,
    bool internationalPronunciation = false,
});

Suggestions #

You can use suggest call to get a list of possible suggestions for your query. This is useful for autocompletion.

Future<List<Suggestion>> suggest(
    String query, {
    int max = 10,
    Vocabulary vocabulary = Vocabulary.basic,
});
3
likes
130
pub points
40%
popularity

Publisher

verified publishervojtech.net

Datamuse API client for Dart/Flutter provides word-finding query engine.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, json_annotation

More

Packages that depend on datamuse