dart_firebase_admin 0.3.1 copy "dart_firebase_admin: ^0.3.1" to clipboard
dart_firebase_admin: ^0.3.1 copied to clipboard

A Firebase Admin SDK implementation for Dart.

36
likes
140/ 160
pub points
87%
popularity

We analyzed this package 17 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

508 out of 701 API elements (72.5 %) have documentation comments.

Some symbols that are missing documentation: auth, auth.ActionCodeSettingsAndroid, auth.ActionCodeSettingsAndroid.ActionCodeSettingsAndroid, auth.ActionCodeSettingsIos, auth.ActionCodeSettingsIos.ActionCodeSettingsIos.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_firebase_admin/dart_firebase_admin.dart that imports:
  • package:dart_firebase_admin/src/app.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/authorization_code_grant_server_flow.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: A value for optional parameter 'providerId' isn't ever given.

lib/src/auth/auth_config.dart:57:10

   ╷
57 │     this.providerId,
   │          ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/auth/auth_config.dart

INFO: A value for optional parameter 'enableRequestSigning' isn't ever given.

lib/src/auth/auth_config.dart:65:10

   ╷
65 │     this.enableRequestSigning,
   │          ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/auth/auth_config.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.19.0 1.19.0
crypto ^3.0.3 3.0.3 3.0.3
dart_jsonwebtoken ^2.11.0 2.14.0 2.14.0
firebaseapis ^0.2.0 0.2.0 0.2.0
freezed_annotation ^2.4.1 2.4.4 2.4.4
googleapis_auth ^1.3.0 1.4.1 1.6.0
http ^1.0.0 1.2.2 1.2.2
intl ^0.19.0 0.19.0 0.19.0
meta ^1.9.1 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
_discoveryapis_commons - 1.0.7 1.0.7
adaptive_number - 1.0.0 1.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
ed25519_edwards - 0.3.1 0.3.1
fixnum - 1.1.0 1.1.0
http_parser - 4.1.0 4.1.0
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 1.0.0 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.