dart_code_metrics 2.4.0
dart_code_metrics: ^2.4.0 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Software analytics tool that helps developers analyse and improve software quality.

23
likes
80 / 110
pub points
91 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 76 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_code_metrics/analyzer_plugin.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin_starter.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin.dart that imports:
  • package:dart_code_metrics/src/analyzer_plugin/analyzer_plugin_utils.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'FeatureSet.fromEnableFlags' is deprecated and shouldn't be used. Use 'fromEnableFlags2' instead.

lib/src/metrics_analyzer.dart:27:21

   ╷
27 │ final _featureSet = FeatureSet.fromEnableFlags([]);
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/metrics_analyzer.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.3 <0.42.00.41.21.1.0
analyzer_plugin>=0.2.1 <0.5.00.4.00.4.0
ansicolor^1.1.01.1.11.1.1
args^1.4.41.6.02.0.0
code_checker>=0.3.3 <0.3.40.3.30.8.0
crypto^2.0.62.1.53.0.0
glob^1.1.71.2.02.0.0
html>=0.13.4 <1.0.00.14.0+40.15.0
meta^1.1.61.2.41.3.0
path^1.6.21.7.01.8.0
quiver^2.0.02.1.53.0.0
source_span^1.4.11.7.01.8.1
yaml^2.1.52.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
async-2.4.22.5.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
csslib-0.16.20.17.0
dart_style-1.3.121.3.14
file-5.2.16.1.0
intl-0.16.10.17.0
js-0.6.20.6.3
matcher-0.12.90.12.10
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `>=0.39.3 <0.42.0` on analyzer does not support the stable version `1.0.0`, that was published 16 days ago.

When analyzer is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.4.4` on args does not support the stable version `2.0.0`, that was published 20 days ago.

When args is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.