large Flutter Favorite logosmall Flutter Favorite logo

dart_code_metrics 4.15.2 icon indicating copy to clipboard operation
dart_code_metrics: ^4.15.2 copied to clipboard

Software analytics tool that helps developers analyse and improve software quality.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate dart_code_metrics

Use it

The package has the following executables:

$ metrics

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add dart_code_metrics

With Flutter:

 $ flutter pub add dart_code_metrics

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  dart_code_metrics: ^4.15.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:dart_code_metrics/analyzer_plugin.dart';
import 'package:dart_code_metrics/config.dart';
import 'package:dart_code_metrics/lint_analyzer.dart';
import 'package:dart_code_metrics/reporters.dart';
import 'package:dart_code_metrics/unused_code_analyzer.dart';
import 'package:dart_code_metrics/unused_files_analyzer.dart';
import 'package:dart_code_metrics/unused_l10n_analyzer.dart';