comm_app 0.0.1-dev copy "comm_app: ^0.0.1-dev" to clipboard
comm_app: ^0.0.1-dev copied to clipboard

flutter app encapsulates basic app functions.

0
likes
130/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 24 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: language, language.LanguageExten, language.LanguageExten.countryCode, language.LanguageExten.languageCode, language.LanguageExten.name.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:comm_app/language/language_utils.dart that imports:
  • package:comm_utils/comm_utils.dart that imports:
  • package:comm_utils/utils/xlog.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
comm_utils ^0.0.2 0.0.6 0.0.6
flutter flutter 0.0.0 0.0.0
json_annotation ^4.6.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
cookie_jar - 3.0.1 4.0.8
crypto - 3.0.3 3.0.3
decimal - 2.3.3 2.3.3
dio - 4.0.6 5.4.3+1
dio_cookie_manager - 2.0.0 3.1.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
logger - 1.4.0 2.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pretty_dio_logger - 1.2.0-beta-1 1.3.1
rational - 2.2.2 2.2.2
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

unverified uploader

flutter app encapsulates basic app functions.

Homepage

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

comm_utils, flutter, json_annotation

More

Packages that depend on comm_app