cloud_firestore_database_wrapper 1.0.1
cloud_firestore_database_wrapper: ^1.0.1 copied to clipboard

A new Flutter package project.

1
likes
100/ 130
pub points
16%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 101 API elements (1.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:cloud_firestore_database_wrapper/cloud_firestore_database_wrapper.dart that imports:
  • package:cloud_firestore_database_wrapper/interfaces/i_data_source.dart that imports:
  • package:cloud_firestore_database_wrapper/util/firestore_parser.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^1.0.41.0.72.5.4
cloud_firestore_mocks^0.8.3+10.8.40.9.0+1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
cloud_firestore_platform_interface-4.0.35.4.3
cloud_firestore_web-1.0.72.4.4
collection-1.15.01.15.0
firebase_core-1.8.01.8.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.4` on cloud_firestore does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^0.8.3+1` on cloud_firestore_mocks does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions cloud_firestore_mocks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.