chessboard_js 0.0.3 copy "chessboard_js: ^0.0.3" to clipboard
chessboard_js: ^0.0.3 copied to clipboard

outdated

A chessboard widget to use with chessjs. Use chessjs for the logic of the game, and this package to display the game.

3
likes
120/ 140
pub points
29%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

118 out of 202 API elements (58.4 %) have documentation comments.

Some symbols that are missing documentation: chess_vectors_flutter, chessboard_model, chessboard_model.ChessboardModel.squares, chessboard_ui, chessboard_ui.ChessBoard.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:chessboard_js/chessboard_js.dart that imports:
  • package:chessboard_js/views/chessboard_ui.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:chessboard_js/chessboard_js.dart that imports:
  • package:chessboard_js/views/chessboard_ui.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:chessboard_js/chessboard_js.dart that imports:
  • package:chessboard_js/views/chessboard_ui.dart that imports:
  • package:audioplayers/audioplayers.dart that imports:
  • package:audioplayers/src/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/chess_vectors/vector_image.dart:2:8

  ╷
2 │ import 'dart:ui' show Color, Offset, Path, Radius;
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/chess_vectors/vector_image.dart

INFO: Statements in an if should be enclosed in a block.

lib/chess_vectors/vector_image.dart:608:7

    ╷
608 │       throw "Unrecognized path in $remainingPath !";
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/chess_vectors/vector_image.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers ^0.19.0 0.19.1 6.0.0
chessjs ^0.0.1+6 0.0.1+7 0.0.1+7
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
tuple ^2.0.0 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
benchmark_harness - 2.2.2 2.2.2
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.19.0` on audioplayers does not support the stable version `0.20.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

3
likes
120
pub points
29%
popularity

Publisher

verified publishercarlosalejano.app

A chessboard widget to use with chessjs. Use chessjs for the logic of the game, and this package to display the game.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers, chessjs, equatable, flutter, flutter_web_plugins, tuple

More

Packages that depend on chessboard_js