check_app_version 1.0.0+1 icon indicating copy to clipboard operation
check_app_version: ^1.0.0+1 copied to clipboard

The plugin verifies that the version of the installed app is the most up-to-date, if not, it invites the user to update.

6
likes
130/ 140
pub points
53%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 42 out of 69 API elements (60.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.13.50.13.50.13.5
package_info_plus^1.4.3+11.4.3+13.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.17.01.17.1
ffi-2.0.12.0.1
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.24.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
package_info_plus_linux-1.0.52.0.0
package_info_plus_macos-1.3.02.0.0
package_info_plus_platform_interface-1.0.22.0.1
package_info_plus_web-1.0.62.0.0
package_info_plus_windows-2.1.03.0.0
path-1.8.31.8.3
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-3.1.34.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.4.3+1` on package_info_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

6
likes
130
pub points
53%
popularity

Publisher

verified publisher iconenzodesimone.dev

The plugin verifies that the version of the installed app is the most up-to-date, if not, it invites the user to update.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http, package_info_plus

More

Packages that depend on check_app_version