chatwoot_client_sdk 0.0.8 copy "chatwoot_client_sdk: ^0.0.8" to clipboard
chatwoot_client_sdk: ^0.0.8 copied to clipboard

A flutter client sdk for chatwoot. Integrate Chatwoot flutter client into your flutter app and talk to your visitors/users in real time.

10
likes
100/ 140
pub points
49%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: chatwoot_client_sdk,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: chatwoot_client_sdk.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

231 out of 546 API elements (42.3 %) have documentation comments.

Some symbols that are missing documentation: chatwoot_action, chatwoot_action.ChatwootAction, chatwoot_action.ChatwootAction.ChatwootAction, chatwoot_action.ChatwootAction.command, chatwoot_action.ChatwootAction.data.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

WARNING: Duplicate import.

lib/data/local/local_storage.dart:10:8

   ╷
10 │ import 'entity/chatwoot_conversation.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/data/local/local_storage.dart

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/ui/chatwoot_chat_page.dart:328:28

    ╷
328 │     WidgetsBinding.instance?.addPostFrameCallback((_) {
    │                            ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/chatwoot_chat_page.dart

OK
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.5.0 2.11.0 2.11.0
dio ^4.0.0 4.0.6 5.4.3+1
equatable ^2.0.3 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_chat_types ^2.4.0 2.4.3 3.6.2
flutter_chat_ui ^1.1.9 1.2.0 1.6.13
hive ^2.0.4 2.2.3 2.2.3
hive_flutter ^1.1.0 1.1.0 1.1.0
intl ^0.17.0 0.17.0 0.19.0
json_annotation ^4.0.1 4.9.0 4.9.0
riverpod ^0.14.0+3 0.14.0+3 2.5.1
stream_channel ^2.1.0 2.1.2 2.1.2
synchronized ^3.0.0 3.1.0+1 3.1.0+1
uuid ^3.0.4 3.0.7 4.4.0
web_socket_channel ^2.1.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
diffutil_dart - 2.0.0+1 4.0.1
ffi - 2.1.2 2.1.2
flutter_link_previewer - 2.3.0 3.2.2
flutter_linkify - 5.0.2 6.0.0
flutter_web_plugins - 0.0.0 0.0.0
freezed_annotation - 0.14.3 2.4.1
html - 0.15.4 0.15.4
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
linkify - 4.1.0 5.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
photo_view - 0.12.0 0.15.0
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
state_notifier - 0.7.2+1 1.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher - 6.2.6 6.2.6
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^2.4.0` on flutter_chat_types does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions flutter_chat_types to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

10
likes
100
pub points
49%
popularity

Publisher

verified publisherchatwoot.com

A flutter client sdk for chatwoot. Integrate Chatwoot flutter client into your flutter app and talk to your visitors/users in real time.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, dio, equatable, flutter, flutter_chat_types, flutter_chat_ui, hive, hive_flutter, intl, json_annotation, riverpod, stream_channel, synchronized, uuid, web_socket_channel

More

Packages that depend on chatwoot_client_sdk