card91_transaction 0.0.6 copy "card91_transaction: ^0.0.6" to clipboard
card91_transaction: ^0.0.6 copied to clipboard

Card91 Transaction Plugin

2
likes
70/ 140
pub points
43%
popularity

We analyzed this package 14 hours ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 16 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_transaction_plugin, flutter_transaction_plugin.Card91Transaction, flutter_transaction_plugin.Card91Transaction.Card91Transaction, flutter_transaction_plugin.Card91Transaction.cardId, flutter_transaction_plugin.Card91Transaction.env.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:card91_transaction/card91_transaction.dart that imports:
  • package:card91_transaction/src/card91_transaction_list.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: Unused import: 'package:pdf/pdf.dart'.

lib/src/card91_transaction_list.dart:9:8

  ╷
9 │ import 'package:pdf/pdf.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/card91_transaction_list.dart

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: Card91Transaction.cardId, Card91Transaction.token, Card91Transaction.template, Card91Transaction.env

lib/src/card91_transaction_list.dart:12:7

   ╷
12 │ class Card91Transaction extends StatefulWidget {
   │       ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/card91_transaction_list.dart

failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
get ^4.6.1 4.6.6 4.6.6
open_file_safe ^3.2.3 3.2.3 3.2.3
path_provider ^2.0.11 2.0.15 2.1.2
pdf ^3.8.2 3.10.8 3.10.8
webview_flutter ^3.0.4 3.0.4 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
barcode - 2.2.6 2.2.6
bidi - 2.0.10 2.0.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 1.2.1 2.1.2
image - 4.1.7 4.1.7
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.0.7 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.7.4 3.7.4
qr - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.15.0
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.12.0
win32 - 2.6.1 5.2.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.4` on webview_flutter does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.