busha_commerce_flutter 0.0.2 copy "busha_commerce_flutter: ^0.0.2" to clipboard
busha_commerce_flutter: ^0.0.2 copied to clipboard

Accept bitcoin and other cryptocurrencies from anywhere in the world.

0
likes
60/ 160
pub points
0%
popularity

We analyzed this package 23 hours ago, and awarded it 60 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/bushaHQ/busha-commerce-flutter was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: busha_commerce_flutter,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

33 out of 184 API elements (17.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: busha_commerce_flutter, busha_commerce_flutter.AppWrapper, busha_commerce_flutter.AppWrapper.AppWrapper, busha_commerce_flutter.AppWrapper.allowAppBar, busha_commerce_flutter.AppWrapper.buttonChild.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:busha_commerce_flutter/busha_commerce_flutter.dart that imports:
  • package:busha_commerce_flutter/src/views/views.dart that imports:
  • package:busha_commerce_flutter/src/views/entry/entry_view.dart that imports:
  • package:busha_commerce_flutter/src/views/select_asset/select_payment_asset_view.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:busha_commerce_flutter/busha_commerce_flutter.dart that imports:
  • package:busha_commerce_flutter/src/views/views.dart that imports:
  • package:busha_commerce_flutter/src/views/entry/entry_view.dart that imports:
  • package:busha_commerce_flutter/src/views/select_asset/select_payment_asset_view.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:busha_commerce_flutter/busha_commerce_flutter.dart that imports:
  • package:busha_commerce_flutter/src/views/views.dart that imports:
  • package:busha_commerce_flutter/src/views/entry/entry_view.dart that imports:
  • package:busha_commerce_flutter/src/views/select_asset/select_payment_asset_view.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

ERROR: The getter 'bodyText2' isn't defined for the type 'TextTheme'.

lib/src/views/make_payment/make_payment_view.dart:131:56

    ╷
131 │                     style: Theme.of(context).textTheme.bodyText2!.copyWith(
    │                                                        ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/views/make_payment/make_payment_view.dart

ERROR: The argument type 'QrImage' can't be assigned to the parameter type 'Widget?'.

lib/src/views/make_payment/make_payment_view.dart:180:34

    ╷
180 │                             child: QrImage(
    │ ┌──────────────────────────────────^
181 │ │                             data: address.address!,
182 │ │                             size: 240,
183 │ │                           ),
    │ └───────────────────────────^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/views/make_payment/make_payment_view.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cached_network_image ^3.2.0 3.3.1 3.3.1
flutter flutter 0.0.0 0.0.0
flutter_svg ^1.1.6 1.1.6 2.0.10+1
get_it ^7.2.0 7.7.0 7.7.0
http ^0.13.5 0.13.6 1.2.1
http_interceptor ^1.0.2 1.0.2 1.0.2
intl ^0.18.0 0.18.1 0.19.0
modal_bottom_sheet ^2.1.2 2.1.2 3.0.0
qr_flutter ^4.0.0 4.1.0 4.1.0
stacked ^3.0.0 3.4.3 3.4.3
url_launcher ^6.0.17 6.3.0 6.3.0
web_socket_channel ^2.3.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_cache_manager - 3.3.1 3.3.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
octo_image - 2.0.0 2.0.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
qr - 3.0.1 3.0.1
rxdart - 0.27.7 0.28.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
stacked_shared - 1.4.0 1.4.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.1.6` on flutter_svg does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 20 errors:

  • MIXIN_OF_NON_CLASS - lib/src/core/services/payment_service.dart:7:27 - Classes can only mix in mixins and classes.
  • UNDEFINED_METHOD - lib/src/core/services/payment_service.dart:24:5 - The method 'listenToReactiveValues' isn't defined for the type 'PaymentService'.
  • URI_DOES_NOT_EXIST - lib/src/core/services/url_service.dart:2:8 - Target of URI doesn't exist: 'package:url_launcher/url_launcher_string.dart'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.