build_web_compilers 2.12.2
build_web_compilers: ^2.12.2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Builder implementations wrapping Dart compilers.

9
likes
60 / 110
pub points
94 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 63 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_web_compilers/build_web_compilers.dart that imports:
  • package:build_web_compilers/src/web_entrypoint_builder.dart that imports:
  • package:build_web_compilers/src/dev_compiler_bootstrap.dart that imports:
  • package:build_web_compilers/src/platforms.dart that imports:
  • package:build_modules/build_modules.dart that imports:
  • package:build_modules/src/workers.dart that imports:
  • package:build_modules/src/scratch_space.dart that imports:
  • package:scratch_space/scratch_space.dart that imports:
  • package:scratch_space/src/scratch_space.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'skipPlatformCheckPackages' is deprecated and shouldn't be used.

lib/src/dev_compiler_bootstrap.dart:32:21

   ╷
32 │ /// Deprecated: If [skipPlatformCheckPackages] is provided then any dart:
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dev_compiler_bootstrap.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.36.4 <0.41.00.40.61.1.0
archive^2.0.02.0.133.1.2
bazel_worker^0.1.180.1.250.1.25
build>=1.5.0 <2.0.01.6.21.6.3
build_config>=0.3.0 <0.5.00.4.60.4.6
build_modules^3.0.03.0.43.0.5
collection^1.0.01.14.131.15.0
glob^1.1.01.2.02.0.0
js^0.6.10.6.20.6.3
logging^0.11.20.11.41.0.0
meta^1.1.01.2.41.3.0
path^1.4.21.7.01.8.0
pool^1.3.01.4.01.5.0
scratch_space^0.0.20.0.4+30.0.4+3
source_maps^0.10.40.10.90.10.10
source_span^1.4.01.7.01.8.1
stack_trace^1.9.21.9.61.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
charcode-1.1.31.2.0
checked_yaml-1.0.42.0.0
cli_util-0.2.00.3.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
graphs-0.2.01.0.0
intl-0.16.10.17.0
json_annotation-3.1.14.0.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
pedantic-1.9.21.10.0
protobuf-1.1.32.0.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.80.1.8
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=0.36.4 <0.41.0` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^2.0.0` on archive does not support the stable version `3.0.0`, that was published 26 days ago.

When archive is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions archive to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.