buck 0.1.4+2

Flutter Android

An assembled flutter application framework Buck, Old longings nomadic leap, Chafing at custom's chain.

1
likes
55 / 110
pub points
0 %
popularity

We analyzed this package on Sep 27, 2020, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:53:61

   ╷
53 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 713 API elements (12.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Web

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform Linux

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:buck/buck.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: Unused import: 'package:buck/buck.dart'.

lib/home/tabs/person_tab/person_center.dart:2:8

  ╷
2 │ import 'package:buck/buck.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/home/tabs/person_tab/person_center.dart

INFO: 'subhead' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is subtitle1. This feature was deprecated after v1.13.8..

lib/login/login_page.dart:147:32

    ╷
147 │           hintStyle: textTheme.subhead.copyWith(color: Colors.grey),
    │                                ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/login/login_page.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.0
device_info^0.4.1+40.4.2+80.4.2+8
device_sn^0.1.10.1.10.1.1
dio^3.0.93.0.103.0.10
encrypt^4.0.04.0.34.0.3
flutterflutter0.0.00.0.0
flutter_local_notifications^1.4.01.4.4+41.4.4+4
flutter_spinkit^4.1.24.1.2+14.1.2+1
fluttertoast^4.0.14.0.17.1.1
http_parser^3.1.33.1.43.1.4
open_file^3.0.03.0.13.0.1
package_info>=0.4.0+13 <2.0.00.4.30.4.3
path_provider^1.6.51.6.181.6.18
pda_scanner^0.2.60.2.90.2.9
permission_handler^5.0.0+hotfix.65.0.1+15.0.1+1
pointycastle^1.0.21.0.21.0.2
rxdart^0.24.00.24.10.24.1
shared_preferences^0.5.60.5.120.5.12
vibrate^0.0.40.0.40.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
asn1lib-0.6.50.8.1
characters-1.0.01.0.0
charcode-1.1.31.1.3
clock-1.0.11.0.1
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
device_info_platform_interface-1.0.11.0.1
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_local_notifications_platform_interface-1.0.11.0.1
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.16.1
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
permission_handler_platform_interface-2.0.12.0.1
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
win32-1.7.31.7.3
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:15:20

   ╷
15 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^4.0.1` on fluttertoast does not support the latest published version `7.1.1`

pubspec.yaml:23:17

   ╷
23 │   fluttertoast: ^4.0.1
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs