buck 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new48

buck #

Pub

An assembled flutter application framework.

Old longings nomadic leap, Chafing at custom's chain; Again from its brumal sleep Wakens the ferine stain.

Getting Started #

dependencies:
 buck: ^0.1.1

Completed #

  • [x] 消息推送
  • [x] 后台配置一个账户同一时间是否只允许一台设备在线
  • [x] 远程强制登出
  • [x] 自定义功能点及分组
  • [x] 消息提醒功能
  • [x] 快捷菜单
  • [x] 自定义个人中心通用功能点
  • [x] 点击消息跳转到对应功能点
  • [x] 切换主题(lightdark
  • [x] 一系列自定义组件

Todo #

  • [x] 修改密码
  • [x] 配置服务器地址功能

0.0.1 - 2020/01/16. #

0.0.2 - 2020/01/16. #

0.1.0 - 2020/01/16. #

0.1.1 - 2020/01/16. #

example/README.md

buck_example #

Demonstrates how to use the buck package.

Getting Started #

const BASE_URL = 'http://192.168.0.1:8090/';
const WS_URL = 'ws://192.168.0.1:8091';

const LOGO_PATH = "assets/images/logo.png";
const HOME_TITLE = "BUCK";
const TITLE_LABEL = "BUCK";
const BACKGROUND_PATH = "assets/images/background.png";
const WELCOME_LABEL = "Albert Einstein: Logic will get you from A to B. Imagination will take you everywhere.";

Future<void> main() async {
  Buck buck = Buck.getInstance();
  await buck.init(baseUrl: BASE_URL, wsUrl: WS_URL, menuFree: true);
  buck.installMenus('Alpha', [BundleRest(), BundleDeliver(key: Key('a-deliver'))]);
  buck.installMenus('Beta', [BundleService(), BundleShopping()]);
  buck.installMenus('Gama', [BundleRest(), BundleDeliver(key: Key('c-Deliver')), BundleService(), BundleShopping()]);
  buck.installPianos('Piano Group A', [PianoEarth()]);
  buck.installPianos('Piano Group B', [PianoCollect(), PianoAlbum(), PianoCard(), PianoExpression()]);
  buck.installPianos('Piano Group C', [PianoSetting()]);
  runApp(BasicApp(homeTitle: HOME_TITLE));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  buck: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:buck/buck.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/basic_app.dart.

Run flutter format to format lib/basic_app.dart.

Format lib/buck.dart.

Run flutter format to format lib/buck.dart.

Format lib/bundle/menu_boss.dart.

Run flutter format to format lib/bundle/menu_boss.dart.

Fix additional 33 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/bundle/piano_boss.dart (Run flutter format to format lib/bundle/piano_boss.dart.)
  • lib/home/home_page.dart (Run flutter format to format lib/home/home_page.dart.)
  • lib/home/tabs/menu_tab/menu_bar.dart (Run flutter format to format lib/home/tabs/menu_tab/menu_bar.dart.)
  • lib/home/tabs/menu_tab/menu_center.dart (Run flutter format to format lib/home/tabs/menu_tab/menu_center.dart.)
  • lib/home/tabs/news_tab/news_bar.dart (Run flutter format to format lib/home/tabs/news_tab/news_bar.dart.)
  • lib/home/tabs/news_tab/news_center.dart (Run flutter format to format lib/home/tabs/news_tab/news_center.dart.)
  • lib/home/tabs/news_tab/news_detail.dart (Run flutter format to format lib/home/tabs/news_tab/news_detail.dart.)
  • lib/home/tabs/news_tab/news_item.dart (Run flutter format to format lib/home/tabs/news_tab/news_item.dart.)
  • lib/home/tabs/person_tab/person_bar.dart (Run flutter format to format lib/home/tabs/person_tab/person_bar.dart.)
  • lib/home/tabs/person_tab/person_center.dart (Run flutter format to format lib/home/tabs/person_tab/person_center.dart.)
  • lib/home/widgets/bottom_navy_bar.dart (Run flutter format to format lib/home/widgets/bottom_navy_bar.dart.)
  • lib/login/login_page.dart (Run flutter format to format lib/login/login_page.dart.)
  • lib/login/widgets/forward_button.dart (Run flutter format to format lib/login/widgets/forward_button.dart.)
  • lib/login/widgets/header_text.dart (Run flutter format to format lib/login/widgets/header_text.dart.)
  • lib/message/notifier.dart (Run flutter format to format lib/message/notifier.dart.)
  • lib/message/socket_client.dart (Run flutter format to format lib/message/socket_client.dart.)
  • lib/service/cache_control.dart (Run flutter format to format lib/service/cache_control.dart.)
  • lib/service/message_box.dart (Run flutter format to format lib/service/message_box.dart.)
  • lib/service/version_control.dart (Run flutter format to format lib/service/version_control.dart.)
  • lib/utils/dio_client.dart (Run flutter format to format lib/utils/dio_client.dart.)
  • lib/utils/login_client.dart (Run flutter format to format lib/utils/login_client.dart.)
  • lib/widgets/dialogs/expound_dialog.dart (Run flutter format to format lib/widgets/dialogs/expound_dialog.dart.)
  • lib/widgets/dialogs/upgrade_dialog.dart (Run flutter format to format lib/widgets/dialogs/upgrade_dialog.dart.)
  • lib/widgets/dialogs/whether_dialog.dart (Run flutter format to format lib/widgets/dialogs/whether_dialog.dart.)
  • lib/widgets/dynamic_list.dart (Run flutter format to format lib/widgets/dynamic_list.dart.)
  • lib/widgets/form/constant/formatter_constant.dart (Run flutter format to format lib/widgets/form/constant/formatter_constant.dart.)
  • lib/widgets/form/headline.dart (Run flutter format to format lib/widgets/form/headline.dart.)
  • lib/widgets/form/multi_election.dart (Run flutter format to format lib/widgets/form/multi_election.dart.)
  • lib/widgets/form/selector.dart (Run flutter format to format lib/widgets/form/selector.dart.)
  • lib/widgets/form/single_election.dart (Run flutter format to format lib/widgets/form/single_election.dart.)
  • lib/widgets/loading/gradient_circular_progress_route.dart (Run flutter format to format lib/widgets/loading/gradient_circular_progress_route.dart.)
  • lib/widgets/loading/loading_progress.dart (Run flutter format to format lib/widgets/loading/loading_progress.dart.)
  • lib/widgets/tips/tips_tool.dart (Run flutter format to format lib/widgets/tips/tips_tool.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_local_notifications).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cupertino_icons ^0.1.2 0.1.3
device_info ^0.4.1+4 0.4.1+4
dio ^3.0.5 3.0.8
flutter 0.0.0
flutter_local_notifications ^0.9.1+3 0.9.1+3 1.1.1
fluttertoast ^3.1.3 3.1.3
open_file ^3.0.0 3.0.1
package_info ^0.4.0+13 0.4.0+13
pda_scanner ^0.2.6 0.2.6
rxdart ^0.23.1 0.23.1
shared_preferences ^0.5.6 0.5.6
vibrate ^0.0.4 0.0.4
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
ffi 0.1.3
flutter_web_plugins 0.0.0
http_parser 3.1.3
meta 1.1.8
path 1.6.4
platform 2.2.1
shared_preferences_macos 0.0.1+3
shared_preferences_platform_interface 1.0.1
shared_preferences_web 0.1.2+2
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test