brick_offline_first_with_rest_build 1.1.3
brick_offline_first_with_rest_build: ^1.1.3 copied to clipboard

Code generation library for the Brick Offline First Domain using REST

0
likes
80/ 130
pub points
31%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 7 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:brick_offline_first_with_rest_build/builder.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/builder.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/offline_first_fields.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because brick_offline_first_with_rest_build depends on brick_build_test from path which doesn't exist (could not find package brick_build_test at "../brick_build_test"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.