box 0.3.1
box: ^0.3.1 copied to clipboard

A fluent Dart persistence API inspired by SQL that supports PostgreSQL, MongoDB, simple file and in-memory storage.

1
likes
80 / 130
pub points
62 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 193 API elements (47.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:box/box.dart that imports:
  • package:box/file.dart that imports:
  • package:box/src/file.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/core.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/file.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.111.15.01.15.0
googleapis_auth^0.2.110.2.12+11.1.0
http^0.12.10.12.20.13.3
inflection2^0.4.20.4.30.4.3
io^0.3.30.3.51.0.3
meta^1.1.81.7.01.7.0
mongo_dart^0.4.30.4.40.7.0+2
postgres^2.1.12.2.02.3.2
recase^3.0.03.0.14.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
basic_utils-2.7.13.3.3
bson-0.3.41.0.3
buffer-1.1.11.1.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
json_annotation-3.1.14.1.0
logging-0.11.41.0.1
mongo_dart_query-0.4.21.0.2
more-2.8.03.1.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-2.0.13.1.3
pool-1.5.01.5.0
rational-0.3.81.2.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.2.11` on googleapis_auth does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions googleapis_auth to update the constraint.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

1
likes
80
pub points
62%
popularity

A fluent Dart persistence API inspired by SQL that supports PostgreSQL, MongoDB, simple file and in-memory storage.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, googleapis_auth, http, inflection2, io, meta, mongo_dart, postgres, recase

More

Packages that depend on box