bea_flutter_package 1.1.3
bea_flutter_package: ^1.1.3 copied to clipboard

BEA Flutter Package, contains all the basic functionality of the standard BEA system. It only works with the BEA framework system and APIs.

0
likes
60 / 110
pub points
13 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 459 API elements (0.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:bea_flutter_package/bea_flutter_package.dart that imports:
  • package:f_logs/f_logs.dart that imports:
  • package:f_logs/utils/storage/logs_storage.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 53 issues. Showing the first 2:

INFO: Unused import: 'dart:convert'.

lib/bea_services/core/bea_defaults_manager.dart:2:8

  ╷
2 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/bea_services/core/bea_defaults_manager.dart

INFO: Unused import: 'dart:convert'.

lib/bea_services/core/bea_roles_manager.dart:2:8

  ╷
2 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/bea_services/core/bea_roles_manager.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.80.4.9+53.0.3
dio^3.0.93.0.104.0.0
f_logs^1.2.21.2.21.2.2
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.33.3.54.1.0
http^0.12.10.12.20.13.1
http_parser^3.1.33.1.44.0.0
json_annotation^3.0.13.1.14.0.1
mime^0.9.6+30.9.71.0.0
path^1.6.41.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.17.0
js-0.6.30.6.3
meta-1.3.01.3.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
permission_handler-4.4.0+hotfix.46.1.3
permission_handler_platform_interface-1.0.03.1.3
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
sembast-2.4.10+43.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
xxtea-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.4.8` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`, that was published 16 days ago.

When dio is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
60
pub points
13%
popularity

BEA Flutter Package, contains all the basic functionality of the standard BEA system. It only works with the BEA framework system and APIs.

Homepage

Documentation

API reference

Uploader

partners@lumete.it

License

MIT (LICENSE)

Dependencies

connectivity, dio, f_logs, flutter, flutter_secure_storage, http, http_parser, json_annotation, mime, path

More

Packages that depend on bea_flutter_package