bd_l10n 1.4.1 copy "bd_l10n: ^1.4.1" to clipboard
bd_l10n: ^1.4.1 copied to clipboard

Tools that help manage localization for a dart/flutter application.

10
likes
130/ 140
pub points
46%
popularity

We analyzed this package 18 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

32 out of 33 API elements (97.0 %) have documentation comments.

Some symbols that are missing documentation: bd_l10n.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:bd_l10n/bd_l10n.dart that imports:
  • package:bd_l10n/src/localization_watcher.dart that imports:
  • package:bd_l10n/src/utils.dart that imports:
  • package:io/io.dart that imports:
  • package:io/src/shared_stdin.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args >=2.0.0 <3.0.0 2.4.2 2.4.2
build >=2.0.0 <3.0.0 2.4.1 2.4.1
build_config >=1.0.0 <2.0.0 1.1.1 1.1.1
io >=1.0.0 <2.0.0 1.0.4 1.0.4
json_annotation >=4.8.0 <5.0.0 4.8.1 4.8.1
meta >=1.3.0 <3.0.0 1.12.0 1.12.0
path >=1.8.1 <2.0.0 1.9.0 1.9.0
watcher >=1.1.0 <2.0.0 1.1.0 1.1.0
yaml >=3.0.0 <4.0.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
async - 2.11.0 2.11.0
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

10
likes
130
pub points
46%
popularity

Publisher

unverified uploader

Tools that help manage localization for a dart/flutter application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

args, build, build_config, io, json_annotation, meta, path, watcher, yaml

More

Packages that depend on bd_l10n