audioplayers 6.0.0 copy "audioplayers: ^6.0.0" to clipboard
audioplayers: ^6.0.0 copied to clipboard

A Flutter plugin to play multiple audio files simultaneously

2803
likes
140/ 140
pub points
100%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

112 out of 210 API elements (53.3 %) have documentation comments.

Some symbols that are missing documentation: audioplayers, audioplayers.AndroidAudioFocus.AndroidAudioFocus.fromInt, audioplayers.AndroidAudioFocus.value, audioplayers.AndroidAudioMode.AndroidAudioMode.fromInt, audioplayers.AndroidAudioMode.value.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:audioplayers/audioplayers.dart that imports:
  • package:audioplayers/src/source.dart that imports:
  • package:audioplayers/src/audioplayer.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers_android ^5.0.0 5.0.0 5.0.0
audioplayers_darwin ^6.0.0 6.0.0 6.0.0
audioplayers_linux ^4.0.0 4.0.0 4.0.0
audioplayers_platform_interface ^7.0.0 7.0.0 7.0.0
audioplayers_web ^5.0.0 5.0.0 5.0.0
audioplayers_windows ^4.0.0 4.0.0 4.0.0
file >=6.1.0 <8.0.0 7.0.0 7.0.0
flutter flutter 0.0.0 0.0.0
http >=0.13.1 <2.0.0 1.2.1 1.2.1
meta ^1.7.0 1.12.0 1.15.0
path_provider ^2.0.12 2.1.3 2.1.3
synchronized ^3.0.0 3.1.0+1 3.1.0+1
uuid >=3.0.7 <5.0.0 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.