assets_gen 1.1.2
assets_gen: ^1.1.2 copied to clipboard

The assets_gen package helps you to generate a .dart file that contains all assets according to `pubspec.yaml`.

7
likes
90/ 130
pub points
58%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:assets_gen/assets_gen.dart that imports:
  • package:assets_gen/src/assets_builder.dart that imports:
  • package:assets_gen/src/pubspec.dart that imports:
  • package:assets_gen/src/options.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor>=1.1.0 <3.0.02.0.12.0.1
args>=1.0.0 <3.0.02.3.02.3.0
build>=1.0.0 <3.0.02.1.12.1.1
glob>=1.2.0 <3.0.02.0.22.0.2
logging>=0.11.4 <2.0.01.0.21.0.2
path>=1.6.0 <2.0.01.8.01.8.0
watcher>=0.9.7 <2.0.01.0.11.0.1
yaml>=2.2.0 <4.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
analyzer-2.6.02.6.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

7
likes
90
pub points
58%
popularity

The assets_gen package helps you to generate a .dart file that contains all assets according to `pubspec.yaml`.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

ansicolor, args, build, glob, logging, path, watcher, yaml

More

Packages that depend on assets_gen