animagie_audio_trimmer 0.0.3 copy "animagie_audio_trimmer: ^0.0.3" to clipboard
animagie_audio_trimmer: ^0.0.3 copied to clipboard

A new animagie_audio_trimmer package project.

0
likes
120/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

45 out of 75 API elements (60.0 %) have documentation comments.

Some symbols that are missing documentation: animagie_audio_trimmer, animagie_audio_trimmer.DurationFormatExt, animagie_audio_trimmer.DurationFormatExt.format, animagie_audio_trimmer.DurationStyle, animagie_audio_trimmer.DurationStyle.DurationStyle.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:animagie_audio_trimmer/animagie_audio_trimmer.dart that imports:
  • package:animagie_audio_trimmer/src/trim_viewer/trim_viewer.dart that imports:
  • package:animagie_audio_trimmer/src/trimmer.dart that imports:
  • package:ffmpeg_kit_flutter/return_code.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:animagie_audio_trimmer/animagie_audio_trimmer.dart that imports:
  • package:animagie_audio_trimmer/src/trim_viewer/trim_viewer.dart that imports:
  • package:animagie_audio_trimmer/src/trimmer.dart that imports:
  • package:ffmpeg_kit_flutter/return_code.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:animagie_audio_trimmer/animagie_audio_trimmer.dart that imports:
  • package:animagie_audio_trimmer/src/trim_viewer/trim_viewer.dart that imports:
  • package:animagie_audio_trimmer/src/trimmer.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The value of the local variable 'i' isn't used.

lib/src/trim_viewer/fixed_viewer/fixed_bar_viewer.dart:41:9

   ╷
41 │     int i = 0;
   │         ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/trim_viewer/fixed_viewer/fixed_bar_viewer.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers ^3.0.1 3.0.1 6.0.0
ffmpeg_kit_flutter ^5.1.0-LTS 5.1.0 6.0.3
flutter flutter 0.0.0 0.0.0
intl ^0.17.0 0.17.0 0.19.0
path ^1.8.2 1.9.0 1.9.0
path_provider ^2.0.11 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
audioplayers_android - 2.0.0 5.0.0
audioplayers_darwin - 3.0.1 6.0.0
audioplayers_linux - 1.0.4 4.0.0
audioplayers_platform_interface - 4.0.0 7.0.0
audioplayers_web - 2.2.0 5.0.0
audioplayers_windows - 1.1.3 4.0.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
ffmpeg_kit_flutter_platform_interface - 0.2.1 0.2.1
flutter_web_plugins - 0.0.0 0.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.1.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.1` on audioplayers does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

The constraint `^5.1.0-LTS` on ffmpeg_kit_flutter does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions ffmpeg_kit_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
120
pub points
0%
popularity

Publisher

unverified uploader

A new animagie_audio_trimmer package project.

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers, ffmpeg_kit_flutter, flutter, intl, path, path_provider

More

Packages that depend on animagie_audio_trimmer