amplify_flutter 1.8.0 copy "amplify_flutter: ^1.8.0" to clipboard
amplify_flutter: ^1.8.0 copied to clipboard

The top level Flutter package for the AWS Amplify libraries.

189
likes
140/ 140
pub points
98%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/aws-amplify/amplify-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2036 out of 2583 API elements (78.8 %) have documentation comments.

Some symbols that are missing documentation: amplify_flutter, amplify_flutter.APIAuthorizationType.authProviderToken, amplify_flutter.APICategory, amplify_flutter.APICategory.APICategory, amplify_flutter.APICategory.category.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/utils/file_key_value_store.dart that declares support for platforms: iOS, Windows, Linux, macOS, Web.
Package does not support platform `iOS`.

Because:

  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_flutter/src/amplify_impl.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amplify_core >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_secure_storage >=0.4.3 <0.5.0 0.4.3 0.4.3
aws_common >=0.6.4 <0.7.0 0.6.4 0.6.4
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.11.0 1.14.0
Transitive dependencies
Package Constraint Compatible Latest
amplify_secure_storage_dart - 0.4.4 0.4.4
async - 2.11.0 2.11.0
aws_signature_v4 - 0.5.2 0.5.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
graphs - 2.3.1 2.3.1
http2 - 2.3.0 2.3.0
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
mime - 1.0.5 1.0.5
os_detect - 2.0.1 2.0.1
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
retry - 3.1.2 3.1.2
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
worker_bee - 0.2.4 0.2.4
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.