amplify_core 1.8.0 copy "amplify_core: ^1.8.0" to clipboard
amplify_core: ^1.8.0 copied to clipboard

The base package containing common types and utilities that are shared across the Amplify Flutter packages.

41
likes
140/ 140
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1918 out of 2433 API elements (78.8 %) have documentation comments.

Some symbols that are missing documentation: Auth, amplify_core, amplify_core.APIAuthorizationType.authProviderToken, amplify_core.APICategory, amplify_core.APICategory.APICategory.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.10.0 2.11.0 2.11.0
aws_common >=0.6.4 <0.7.0 0.6.4 0.6.4
aws_signature_v4 >=0.5.2 <0.6.0 0.5.2 0.5.2
collection ^1.15.0 1.18.0 1.18.0
graphs ^2.1.0 2.3.1 2.3.1
intl >=0.18.0 <1.0.0 0.19.0 0.19.0
json_annotation >=4.8.1 <4.9.0 4.8.1 4.8.1
logging ^1.0.0 1.2.0 1.2.0
meta ^1.7.0 1.14.0 1.14.0
retry ^3.1.0 3.1.2 3.1.2
stack_trace ^1.10.0 1.11.1 1.11.1
uuid >=3.0.6 <5.0.0 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http2 - 2.3.0 2.3.0
js - 0.6.7 0.7.1
mime - 1.0.5 1.0.5
os_detect - 2.0.1 2.0.1
path - 1.9.0 1.9.0
sprintf - 7.0.0 7.0.0
stream_transform - 2.1.0 2.1.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

41
likes
140
pub points
93%
popularity

Publisher

verified publisheraws-amplify.com

The base package containing common types and utilities that are shared across the Amplify Flutter packages.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

async, aws_common, aws_signature_v4, collection, graphs, intl, json_annotation, logging, meta, retry, stack_trace, uuid

More

Packages that depend on amplify_core