amplify_core 0.2.6
amplify_core: ^0.2.6 copied to clipboard

The base package containing common types and utilities that are shared across the Amplify Flutter packages.

example/lib/main.dart

import 'package:flutter/material.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('A simple flutter example\n'),
        ),
      ),
    );
  }
}
28
likes
120
pub points
95%
popularity

Publisher

aws-amplify.com

The base package containing common types and utilities that are shared across the Amplify Flutter packages.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, meta, plugin_platform_interface, uuid

More

Packages that depend on amplify_core