altfire_authenticator 0.1.1 copy "altfire_authenticator: ^0.1.1" to clipboard
altfire_authenticator: ^0.1.1 copied to clipboard

altfire_authenticator is a package wrapping FlutterFire Authentication. It was created to make Firebase SDK versioning and methods easier to use. It is recommended to use the various altfire packages [...]

2
likes
130/ 140
pub points
65%
popularity

We analyzed this package 45 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/altive/altfire/issues?q=is%3Aopen+is%3Aissue+label%3Aaltfire_authenticator was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

82 out of 107 API elements (76.6 %) have documentation comments.

Some symbols that are missing documentation: altfire_authenticator.AuthCancelled, altfire_authenticator.AuthCancelled.AuthCancelled, altfire_authenticator.AuthCredentialAlreadyInUse, altfire_authenticator.AuthCredentialAlreadyInUse.AuthCredentialAlreadyInUse, altfire_authenticator.AuthException.AuthException.fromError.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:altfire_authenticator/altfire_authenticator.dart that imports:
  • package:altfire_authenticator/src/authenticator.dart that imports:
  • package:altfire_authenticator/src/google_authenticator.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:altfire_authenticator/altfire_authenticator.dart that imports:
  • package:altfire_authenticator/src/signing_method.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:altfire_authenticator/altfire_authenticator.dart that imports:
  • package:altfire_authenticator/src/signing_method.dart that imports:
  • package:firebase_auth/firebase_auth.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
firebase_auth ^4.10.1 4.19.2 4.19.2
firebase_core ^2.21.0 2.30.0 2.30.0
flutter flutter 0.0.0 0.0.0
google_sign_in ^6.1.5 6.2.1 6.2.1
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.30 1.3.30
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
fake_async - 1.3.1 1.3.1
firebase_auth_platform_interface - 7.2.3 7.2.3
firebase_auth_web - 5.11.2 5.11.2
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.15.0 2.15.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
google_identity_services_web - 0.3.1+1 0.3.1+1
google_sign_in_android - 6.1.23 6.1.23
google_sign_in_ios - 5.7.6 5.7.6
google_sign_in_platform_interface - 2.4.5 2.4.5
google_sign_in_web - 0.12.4 0.12.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
leak_tracker - 10.0.0 10.0.5
leak_tracker_flutter_testing - 2.0.1 3.0.5
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.2.1
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
130
pub points
65%
popularity

Publisher

verified publisheraltive.co.jp

altfire_authenticator is a package wrapping FlutterFire Authentication. It was created to make Firebase SDK versioning and methods easier to use. It is recommended to use the various altfire packages as a set.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, firebase_auth, firebase_core, flutter, google_sign_in

More

Packages that depend on altfire_authenticator