alan 0.40.2+1
alan: ^0.40.2+1 copied to clipboard

Pure Dart library to easily integrate with any Cosmos-based chain.

2
likes
70/ 130
pub points
66%
popularity

We analyzed this package 36 hours ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1647 out of 9814 API elements (16.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:alan/alan.dart that imports:
  • package:alan/x/export.dart that imports:
  • package:alan/x/auth/export.dart that imports:
  • package:alan/x/auth/querier.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 228 issues. Showing the first 2:

lib/proto/confio/proofs.pb.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/proto/confio/proofs.pbenum.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.3.01.7.22.8.0
asn1lib^1.0.01.0.31.0.3
bech32^0.2.00.2.10.2.1
bip39^1.0.61.0.61.0.6
convert^3.0.03.0.13.0.1
equatable^2.0.02.0.32.0.3
fixnum^1.0.01.0.01.0.0
grpc^3.0.03.0.23.0.2
hex^0.2.00.2.00.2.0
http^0.13.00.13.40.13.4
json_annotation^4.0.14.1.04.4.0
json_serializable^4.1.04.1.46.1.1
meta^1.3.01.7.01.7.0
pointycastle^3.0.13.4.03.4.0
protobuf^2.0.02.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.031.0.0
archive-3.1.63.1.6
args-2.3.02.3.0
async-2.8.22.8.2
build-2.1.12.1.1
build_config-1.0.01.0.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
file-6.1.26.1.2
glob-2.0.22.0.2
googleapis_auth-1.3.01.3.0
http2-2.0.02.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
logging-1.0.21.0.2
package_config-2.0.22.0.2
path-1.8.01.8.0
pub_semver-2.1.02.1.0
pubspec_parse-1.1.01.2.0
source_gen-1.0.31.2.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^4.1.0` on json_serializable does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions json_serializable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • alan that depends on:
  • json_serializable that depends on:
  • build_config that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Dart 2.15.0.