acdc 1.1.1 copy "acdc: ^1.1.1" to clipboard
acdc: ^1.1.1 copied to clipboard

Dart client for generating an `ACDC` object from provided id, data and schema.

0
likes
140/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: EUPL-1.2.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

15 out of 146 API elements (10.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: acdc, acdc.Acdc, acdc.Acdc.Acdc, acdc.Acdc.api, acdc.Acdc.base.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:acdc/acdc.dart that declares support for platforms: Android, iOS, Windows, macOS.
Package does not support platform `Web`.

Because:

  • package:acdc/acdc.dart that declares support for platforms: Android, iOS, Windows, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_rust_bridge ^1.82.1 1.82.1 1.82.6
meta ^1.8.0 1.12.0 1.15.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
uuid ^3.0.7 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build_cli_annotations - 2.1.0 2.1.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pool - 1.5.1 1.5.1
puppeteer - 3.11.0 3.11.0
shelf - 1.4.1 1.4.1
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.7` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
140
pub points
0%
popularity

Publisher

verified publisherhumancolossus.org

Dart client for generating an `ACDC` object from provided id, data and schema.

Repository (GitHub)
View/report issues

Documentation

API reference

License

EUPL-1.2 (LICENSE)

Dependencies

ffi, flutter, flutter_rust_bridge, meta, plugin_platform_interface, uuid

More

Packages that depend on acdc