aad_oauth 1.0.1 copy "aad_oauth: ^1.0.1" to clipboard
aad_oauth: ^1.0.1 copied to clipboard

A Flutter OAuth package for performing user authentication against Azure Active Directory OAuth2 v2.0 endpoint.

136
likes
130/ 140
pub points
96%
popularity

We analyzed this package 43 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

104 out of 187 API elements (55.6 %) have documentation comments.

Some symbols that are missing documentation: auth_storage, auth_storage.AuthStorage, auth_storage.AuthStorage.AuthStorage, auth_storage.AuthStorage.clear, auth_storage.AuthStorage.emptyToken.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:aad_oauth/aad_oauth.dart that imports:
  • package:aad_oauth/helper/core_oauth.dart that imports:
  • package:aad_oauth/helper/mobile_oauth.dart that imports:
  • package:aad_oauth/request_code.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:aad_oauth/aad_oauth.dart that imports:
  • package:aad_oauth/helper/core_oauth.dart that imports:
  • package:aad_oauth/helper/mobile_oauth.dart that imports:
  • package:aad_oauth/request_code.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:aad_oauth/aad_oauth.dart that imports:
  • package:aad_oauth/helper/core_oauth.dart that imports:
  • package:aad_oauth/helper/mobile_oauth.dart that imports:
  • package:aad_oauth/request_code.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:aad_oauth/aad_oauth.dart that imports:
  • package:aad_oauth/model/config.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dartz ^0.10.1 0.10.1 0.10.1
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
flutter_secure_storage ^9.0.0 9.0.0 9.0.0
http ^1.1.0 1.2.1 1.2.1
js ^0.6.7 0.6.7 0.7.1
shared_preferences ^2.2.1 2.2.2 2.2.2
webview_flutter ^4.4.1 4.7.0 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_secure_storage_linux - 1.2.0 1.2.0
flutter_secure_storage_macos - 3.0.1 3.0.1
flutter_secure_storage_platform_interface - 1.0.2 1.0.2
flutter_secure_storage_web - 1.1.2 1.1.2
flutter_secure_storage_windows - 3.0.0 3.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
webview_flutter_android - 3.15.0 3.15.0
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.12.0 3.12.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.7` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

136
likes
130
pub points
96%
popularity

Publisher

verified publisherearlybyte.ch

A Flutter OAuth package for performing user authentication against Azure Active Directory OAuth2 v2.0 endpoint.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dartz, equatable, flutter, flutter_secure_storage, http, js, shared_preferences, webview_flutter

More

Packages that depend on aad_oauth