x509 0.1.3
x509: ^0.1.3

Dart native js
Flutter Android iOS web

Dart library for parsing and working with X.509 certificates.

1
likes
100 / 110
pub points
93 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 61 out of 180 API elements (33.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.6.00.6.50.8.1
crypto_keys^0.1.30.1.30.1.3
quiver^2.0.02.1.52.1.5
Transitive dependencies
PackageConstraintCompatibleLatest
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
collection-1.14.131.14.13
fixnum-0.10.110.10.11
matcher-0.12.90.12.9
meta-1.2.41.2.4
path-1.7.01.7.0
pointycastle-1.0.22.0.0
stack_trace-1.9.61.9.6

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on asn1lib does not support the latest published version `0.8.1`

pubspec.yaml:10:12

   ╷
10 │   asn1lib: ^0.6.0
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
93%
popularity

Publisher

appsup.be

Dart library for parsing and working with X.509 certificates.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

asn1lib, crypto_keys, quiver

More

Packages that depend on x509