winmd 0.4.12
winmd: ^0.4.12 copied to clipboard

A Dart library for working with Windows Metadata (winmd) formats.

1
likes
110 / 130
pub points
37 %
popularity

We analyzed this package on May 17, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 62 out of 522 API elements (11.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:winmd/winmd.dart that imports:
  • package:winmd/src/projection/typeprojector.dart that imports:
  • package:winmd/src/typeidentifier.dart that imports:
  • package:winmd/src/utils.dart that imports:
  • package:winmd/src/typedef.dart that imports:
  • package:winmd/src/method.dart that imports:
  • package:winmd/src/parameter.dart that imports:
  • package:winmd/src/com/IMetaDataImport2.dart that imports:
  • package:winmd/src/com/IMetaDataImport.dart that imports:
  • package:win32/win32.dart that imports:
  • package:win32/src/com/IWbemServices.dart that imports:
  • package:win32/src/com/IUnknown.dart that imports:
  • package:win32/src/utils.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/allocation.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^1.0.01.0.01.0.0
win32^2.0.52.0.52.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

1
likes
110
pub points
37%
popularity

Publisher

sneath.org

A Dart library for working with Windows Metadata (winmd) formats.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

ffi, win32

More

Packages that depend on winmd