wallet_hd 0.0.2
wallet_hd: ^0.0.2 copied to clipboard

A Flutter package project , it is use for HD wallet . Support BTC, ETH, ERC20-USDT transfer signature.

4
likes
70/ 130
pub points
28%
popularity

We analyzed this package 30 hours ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 50 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:wallet_hd/wallet_hd.dart that imports:
  • package:web3dart/web3dart.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/src/check_types.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/ecurve.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bech32^0.1.20.1.20.2.1
bip32^1.0.51.0.72.0.0
bip39^1.0.31.0.31.0.6
bitcoin_flutter^2.0.12.0.22.0.2
bs58check^1.0.11.0.11.0.2
crypton^1.0.81.1.12.0.3
flutterflutter0.0.00.0.0
hex^0.1.20.1.20.2.0
meta^1.1.81.7.01.7.0
pointycastle^1.0.21.0.23.4.0
rlp^1.0.11.0.11.0.1
typed_data^1.2.01.3.01.3.0
web3dart^1.2.31.2.32.3.3
Transitive dependencies
PackageConstraintCompatibleLatest
asn1lib-0.6.51.0.3
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http-0.12.20.13.4
http_parser-3.1.44.0.0
isolate-2.1.12.1.1
json_rpc_2-2.2.23.0.1
path-1.8.01.8.0
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
uuid-2.2.23.0.5
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.1.2` on bech32 does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions bech32 to update the constraint.

The constraint `^1.0.5` on bip32 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions bip32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

4
likes
70
pub points
28%
popularity

A Flutter package project , it is use for HD wallet . Support BTC, ETH, ERC20-USDT transfer signature.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bech32, bip32, bip39, bitcoin_flutter, bs58check, crypton, flutter, hex, meta, pointycastle, rlp, typed_data, web3dart

More

Packages that depend on wallet_hd