vyuh_extension_content 1.4.3 copy "vyuh_extension_content: ^1.4.3" to clipboard
vyuh_extension_content: ^1.4.3 copied to clipboard

An extension for the Vyuh framework for creating CMS integrations

0
likes
130/ 160
pub points
79%
popularity

We analyzed this package 11 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/vyuh-tech/vyuh/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

20 out of 101 API elements (19.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: action, action.Action, action.Action.Action, action.Action.configurationList, action.Action.configurations.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:vyuh_extension_content/vyuh_extension_content.dart that imports:
  • package:vyuh_extension_content/ui/route_builder.dart that imports:
  • package:vyuh_core/vyuh_core.dart that imports:
  • package:vyuh_core/plugin/network/http_network_plugin.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
flutter_mobx ^2.2.0+2 2.2.1+1 2.2.1+1
flutter_sanity_portable_text ^1.3.0 1.3.4 1.3.4
json_annotation ^4.9.0 4.9.0 4.9.0
mobx ^2.3.0+1 2.3.3+2 2.3.3+2
vyuh_core ^1.11.0 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cached_network_image - 3.3.1 3.3.1
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_cache_manager - 3.3.2 3.3.2
flutter_web_plugins - 0.0.0 0.0.0
get_it - 7.7.0 7.7.0
go_router - 14.2.1 14.2.1
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
logger - 2.4.0 2.4.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nanoid - 1.0.0 1.0.0
nested - 1.0.0 1.0.0
octo_image - 2.0.0 2.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
retry - 3.1.2 3.1.2
rxdart - 0.27.7 0.28.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.3.0 1.3.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
web - 1.0.0 1.0.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.