vue 0.4.2
vue: ^0.4.2 copied to clipboard

Vue bindings for Dart

14
likes
50 / 130
pub points
48 %
popularity

We analyzed this package on May 18, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 379 API elements (0.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:vue/vue.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 102 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/builders.dart:115:5

    ╷
115 │ ┌     new Map.fromIterable(
116 │ │       ann.arguments.arguments
117 │ │         .where((arg) => arg is NamedExpression)
118 │ │         .cast<NamedExpression>(),
119 │ │       key: (arg) => arg.name.label.name,
120 │ │       value: (arg) => arg.expression,
121 │ │     );
    │ └─────^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builders.dart

INFO: Prefer to use whereType on iterable.

lib/builders.dart:117:10

    ╷
117 │         .where((arg) => arg is NamedExpression)
    │          ^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/builders.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.37.0 <0.39.00.38.51.5.0
async^2.0.72.6.12.6.1
build^1.1.61.6.22.0.1
csslib^0.14.40.14.6+10.17.0
html^0.13.30.13.4+20.15.0
js^0.6.10.6.30.6.3
sass^1.8.01.32.81.32.13
sass_builder^2.1.02.1.32.1.4
scopify^0.2.10.2.20.2.2
source_maps^0.10.60.10.100.10.10
source_span^1.4.01.8.11.8.1
uuid^1.0.01.0.33.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
build_config-0.4.71.0.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_repl-0.2.20.2.2
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
file-5.2.16.1.1
front_end-0.1.270.1.29
glob-1.2.02.0.1
http-0.12.20.13.3
http_parser-3.1.44.0.0
intl-0.17.00.17.0
json_annotation-4.0.14.0.1
kernel-0.3.270.3.29
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
package_resolver-1.0.101.0.10
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
quiver-2.1.53.0.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
utf-0.9.0+50.9.0+5
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `>=0.37.0 <0.39.0` on analyzer does not support the stable version `0.39.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.1.6` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.