validate_firebase_auth 0.0.1
validate_firebase_auth: ^0.0.1 copied to clipboard

Validates Firebase auth tokens for verifying authentication on server-side applications.

5
likes
110/ 130
pub points
25%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 7 API elements (85.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:validate_firebase_auth/validate_firebase_auth.dart that imports:
  • package:validate_firebase_auth/src/validate_firebase_auth.dart that imports:
  • package:http/io_client.dart that imports:
  • package:http/src/io_streamed_response.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.30.13.40.13.4
meta^1.4.01.7.01.7.0
openid_client^0.4.10.4.30.4.3
very_good_analysis^2.0.02.4.02.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
asn1lib-1.0.31.0.3
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto_keys-0.3.00.3.0
http_parser-4.0.04.0.0
jose-0.3.20.3.2
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
path-1.8.01.8.0
pointycastle-3.4.03.4.0
quiver-3.0.1+13.0.1+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
x509-0.2.20.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

5
likes
110
pub points
25%
popularity

Validates Firebase auth tokens for verifying authentication on server-side applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, meta, openid_client, very_good_analysis

More

Packages that depend on validate_firebase_auth