upcode_ci 0.6.3
upcode_ci: ^0.6.3 copied to clipboard

A starting point for Dart libraries or applications.

4
likes
70/ 130
pub points
12%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

bin/main.dart doesn't match the Dart formatter.

To format your files run: dart format .

bin/upcode.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.2.02.3.02.3.0
geodesy^0.3.20.3.20.3.2
googleapis^5.0.05.0.16.0.0
googleapis_auth^1.1.01.2.01.2.0
googleapis_beta^5.0.05.0.06.0.0
http^0.13.30.13.40.13.4
http_multi_server^3.0.13.0.13.0.1
intl^0.17.00.17.00.17.0
path^1.8.01.8.01.8.0
pub_semver^2.0.02.1.02.1.0
strings^0.2.20.2.20.2.2
uuid^3.0.43.0.53.0.5
xml^5.1.05.3.15.3.1
xml2json^5.3.15.3.15.3.1
yaml^3.1.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.21.0.2
ansicolor-1.1.12.0.1
async-2.8.22.8.2
characters-1.2.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
console_log_handler-1.1.61.1.6
crypto-3.0.13.0.1
http_parser-4.0.04.0.0
latlong-0.6.10.6.1
lists-1.0.11.0.1
logging-0.11.41.0.2
meta-1.7.01.7.0
petitparser-4.4.04.4.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unicode-0.3.10.3.1
validate-1.7.01.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.0` on googleapis does not support the stable version `6.0.0`, that was published 8 days ago.

When googleapis is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

The constraint `^5.0.0` on googleapis_beta does not support the stable version `6.0.0`, that was published 8 days ago.

When googleapis_beta is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions googleapis_beta to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.