up 0.0.1

Dart native

Dart Web application container; run multiple apps in one VM.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Oct 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 44 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:up/up.dart that imports:
  • package:up/src/lambda/server.dart that imports:
  • package:up/src/models.dart that imports:
  • package:up/src/models/lambda.dart that imports:
  • package:body_parser/body_parser.dart that imports:
  • package:body_parser/src/parse_body.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_client^2.0.02.0.22.0.2
angel_framework^2.0.02.1.12.1.1
args^1.0.01.6.01.6.0
body_parser^1.0.01.1.11.1.1
cli_util^0.1.30.1.40.2.0
dbcrypt^1.0.01.0.01.0.0
http^0.12.00.12.20.12.2
http_parser^3.0.03.1.43.1.4
io^0.3.20.3.40.3.4
json_annotation^3.0.03.1.03.1.0
json_rpc_2^2.0.02.2.22.2.2
logging^0.11.00.11.40.11.4
path^1.0.01.7.01.7.0
pretty_logging^1.0.01.0.01.0.0
prompts^1.0.01.3.11.3.1
pubspec_parse^0.1.50.1.50.1.5
stream_channel^2.0.02.0.02.0.0
yaml^2.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.4.22.4.2
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.15.2.1
http2-1.0.11.0.1
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
json_god-2.0.0-beta+32.0.0-beta+3
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
pub_semver-1.4.41.4.4
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on cli_util does not support the latest published version `0.2.0`

pubspec.yaml:13:13

   ╷
13 │   cli_util: ^0.1.3
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs