tiki_sdk_dart 3.0.0 copy "tiki_sdk_dart: ^3.0.0" to clipboard
tiki_sdk_dart: ^3.0.0 copied to clipboard

discontinuedreplaced by: tiki_trail

Create and enforce immutable data licensing records client-side. The core-implementation of TIKI's client-side infrastructure.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Documentation URL doesn't exist.

At the time of the analysis https://docs.mytiki.com/docs/sdk-overview was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: tiki_sdk_dart,
    • contains a version property, and,
    • does not contain a publish_to property.

Could not find any pubspec.yaml in the repository.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting tiki_sdk_dart... Discovering libraries... Linking elements... Precaching local docs for 16914 elements... ERR: dartdoc 8.0.4 (/tmp/analyzerNQVWQE/pub-cache/global_packages/dartdoc/bin/dartdoc.dart-3.3.0.snapshot) failed: Null check operator used on a null value #0 ModelElement._constructFromElementDeclaration (package:dartdoc/src/model/model_element.dart:316:71) #1 new ModelElement._from (package:dartdoc/src/model/model_element.dart:272:40) #2 new ModelElement._fromElement (package:dartdoc/src/model/model_element.dart:156:25) #3 ModelElementBuilderImpl.fromElement (package:dartdoc/src/model/model_element.dart:73:20) #4 ModelElement.definingLibrary (package:dartdoc/src/model/model_element.dart:482:20) #5 ModelElement.canonicalLibrary.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:tiki_sdk_dart/cache/license/license_model.dart that imports:
  • package:tiki_sdk_dart/cache/license/license_repository.dart that imports:
  • package:tiki_sdk_dart/cache/title/title_repository.dart that imports:
  • package:tiki_sdk_dart/cache/title/title_model.dart that imports:
  • package:tiki_sdk_dart/tiki_sdk.dart that imports:
  • package:tiki_sdk_dart/title.dart that imports:
  • package:tiki_sdk_dart/cache/title/title_service.dart that imports:
  • package:tiki_sdk_dart/node/node_service.dart that imports:
  • package:tiki_sdk_dart/node/xchain/xchain_service.dart that imports:
  • package:tiki_sdk_dart/node/transaction/transaction_service.dart that imports:
  • package:tiki_sdk_dart/utils/rsa/rsa.dart that imports:
  • package:tiki_sdk_dart/utils/isolate.dart that imports:
  • dart:isolate
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/utils/isolate.dart:4:1

  ╷
4 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/utils/isolate.dart

INFO: Dangling library doc comment.

lib/utils/rsa/rsa_private_key.dart:5:1

  ╷
5 │ /// @nodoc
  │ ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/utils/rsa/rsa_private_key.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
html ^0.15.3 0.15.4 0.15.4
http ^1.0.0 1.2.1 1.2.1
pointycastle ^3.7.3 3.7.4 3.7.4
sqlite3 ^1.11.2 1.11.2 2.4.0
uuid ^3.0.7 3.0.7 4.3.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.11.2` on sqlite3 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sqlite3 to update the constraint.

The constraint `^3.0.7` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

verified publishermytiki.com

Create and enforce immutable data licensing records client-side. The core-implementation of TIKI's client-side infrastructure.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation

License

MIT (LICENSE)

Dependencies

html, http, pointycastle, sqlite3, uuid

More

Packages that depend on tiki_sdk_dart