tflite_flutter 0.5.0
tflite_flutter: ^0.5.0 copied to clipboard

Flutter Android iOS

TensorFlow Lite Flutter plugin provides easy, flexible and fast Dart API to integrate TFLite models in flutter apps.

72
likes
100 / 110
pub points
91 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 154 API elements (59.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:tflite_flutter/tflite_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.0.0
flutterflutter0.0.00.0.0
path^1.6.21.7.01.8.0
quiver^2.0.32.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
matcher-0.12.90.12.10
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
stack_trace-1.9.61.10.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`, that was published 15 days ago.

When ffi is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^2.0.3` on quiver does not support the stable version `3.0.0`, that was published 9 days ago.

When quiver is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

72
likes
100
pub points
91%
popularity

TensorFlow Lite Flutter plugin provides easy, flexible and fast Dart API to integrate TFLite models in flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

agarg@cs.iitr.ac.in

License

Apache 2.0 (LICENSE)

Dependencies

ffi, flutter, path, quiver

More

Packages that depend on tflite_flutter