taboola_sdk 0.0.2+3

Flutter Android iOS

Taboola Flutter project.

2
likes
70 / 110
pub points
38 %
popularity

We analyzed this package on Sep 21, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 163 API elements (15.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:taboola_sdk/descriptors/application_descriptor.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:taboola_sdk/descriptors/application_descriptor.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:taboola_sdk/descriptors/application_descriptor.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:taboola_sdk/descriptors/application_descriptor.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

INFO: The value of the field '_undefinedValue' isn't used.

lib/descriptors/device_descriptor.dart:15:16

   ╷
15 │   static const _undefinedValue = "undefined";
   │                ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/descriptors/device_descriptor.dart

INFO: Unused import: 'package:taboola_sdk/standard/webview_manager.dart'.

lib/standard/taboola_standard_builder.dart:5:8

  ╷
5 │ import 'package:taboola_sdk/standard/webview_manager.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/standard/taboola_standard_builder.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^0.4.1+40.4.2+70.4.2+7
flutterflutter0.0.00.0.0
package_info^0.4.0+130.4.30.4.3
sim_info^0.1.10.1.10.1.1
system_info^0.1.10.1.30.1.3
webview_flutter^0.3.18+10.3.230.3.23
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
device_info_platform_interface-1.0.11.0.1
file_utils-0.1.40.1.4
globbing-0.3.10.3.1
meta-1.1.81.2.3
path-1.7.01.7.0
plugin_platform_interface-1.0.21.0.2
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs